Tag: Bitbake

Palavra-chave
Destaque/Sem destaque
Resolvida/Não Resolvida
Aberta/Encerrada
0 votos
2k visualizações

Olá,

Uso aqui o kit TORADEX Colibri VF61 com a base Iris. Estou há uns dias tentando executar o comando:

bitbake angstrom-lxde-image

E me retorna o seguinte erro:

ERROR: Function failed: do_install (log file is located at /home/atma/oe-core/build/out-glibc/work/armv7at2hf-vfp-neon-angstrom-linux-gnueabi/scrot/0.8-r0/temp/log.do_install.26966)
ERROR: Logfile of failure stored in: /home/atma/oe-core/build/out-glibc/work/armv7at2hf-vfp-neon-angstrom-linux-gnueabi/scrot/0.8-r0/temp/log.do_install.26966
Log data follows:
| DEBUG: SITE files ['endian-little', 'bit-32', 'arm-common', 'arm-32', 'common-linux', 'common-glibc', 'arm-linux', 'arm-linux-gnueabi', 'common']
| DEBUG: Executing shell function do_install
| NOTE: make -j 2 DESTDIR=/home/atma/oe-core/build/out-glibc/work/armv7at2hf-vfp-neon-angstrom-linux-gnueabi/scrot/0.8-r0/image install
| make: *** No rule to make target `install'.  Stop.
| ERROR: oe_runmake failed
| WARNING: exit code 1 from a shell command.
| ERROR: Function failed: do_install (log file is located at /home/atma/oe-core/build/out-glibc/work/armv7at2hf-vfp-neon-angstrom-linux-gnueabi/scrot/0.8-r0/temp/log.do_install.26966)
ERROR: Task 842 (/home/atma/oe-core/build/../stuff/meta-toradex/recipes-graphics/scrot/scrot_0.8.bb, do_install) failed with exit code '1'

Estou usando a seguinte versão:

Toradex version ==> 2.4
Angström Distribution ==> v2014.12
OpenEmbedded/Yocto Codename ==> dizzy
Yocto Project Release ==> 1.7

Minha distro rodando no VMWare:

Linux Ubuntu 3.19.0-30-generic #33~14.04.1-Ubuntu SMP Tue Sep 22 09:27:41 UTC 2015 i686 i686 i686 GNU/Linux

Consegui gerar o:

bitbake core-image-minimal

Esse scrot (SCReen shOT) antes dava erro na tarefa do_fetch com erro de acesso negado a url fornecida.
Alterei o scrot_0.8.bb com um novo link onde consegui encontrar o scrot-08.tar.gz, refiz o md5sum e tudo que precisa dentro do arquivo.
APARENTEMENTE correu bem….mas agora está dando erro na tarefa do_install.

Estou há dias em cima deste erro. Qualquer ideia é bem vinda.

Mostrando 1 resultado